Here With Me

Le blog technique d'Amaury Balmer qui parle de technologies open-source, mais surtout de WordPress !

WordPress 3.5 : Plus de JavaScript dans la console d’administration

| 76 Commentaires

Si vous faites partie de ces personnes pressées d’avoir fait la mise à jour vers WordPress 3.5, il se peut que le JavaScript ne fonctionne plus dans la console d’administration.

Les symptômes sont les suivants :

  • Les menus déroulants ne fonctionnent plus
  • Les fonctionnalités de glisser/déposer non plus
  • Impossible d’ajouter un média
  • Etc.

Le problème est actuellement étudié par l’équipe de développement, cf ce ticket, mais il existe une solution simple, c’est de tout simplement désactiver la concaténation des JavaScript dans le back-office.

Pour y parvenir, il faut ajouter la ligne suivante dans votre fichier de configuration :

define('CONCATENATE_SCRIPTS', false);

Comme indiqué dans la page du codex détaillant les possibilités du fichier wp-config.php.

Une origine du problème pourrait également être un fichier .htaccess trop restrictif, je vous conseille de lire cet article si vous utilisez le firewall Jeff Starr’s .htaccess ou le plugin BulletProof Security.

76 Commentaires

  1. Bonjour,

    un grand merci pour cette solution qui a fonctionné pour moi. En tout cas partiellement, car je ne peux toujours pas charger des images dans mes articles à partir du bouton de l’éditeur. Mais comme j’ai maintenant accès au code source, j’ai créé mes blocs d’images directement. C’est un peu contraignant, mais au moins, toutes les autres fonctionnalités sont revenues.

    Ouf ! j’avais passé une grande partie de la journée à essayer de comprendre ce qui se passait en désactivant plusieurs plugins sur plusieurs blogs, mais toujours avec des résultats inégaux et incohérents, ce qui m’a amenée à penser que le problème venait probablement de la dernière mise à jour de WP.

    Merci donc pour m’avoir épargné un sérieux casse-tête et pas mal d’heures de recherche dans mes plugins ! :-)

    Ça pourrait nous être utile si vous reveniez nous informer des suites au niveau de WP. Merci d’avance.

    Alexandra

  2. Bonjour,

    J’ai malheureusement fait la mise à jour de mon site avant de prendre connaissance du problème d’ajout de médias. Dans mon cas ce problème est très pénalisant, mon site se trouve donc « gelé » sans possibilité de mise à jour régulière. De plus l’accès aux médias lors de la création d’un post est une étape importante, mon thème sollicite la banque de médias de mon WordPress pour ajouter un « featured image » à chaque post. à la limite, insérer une image dans le corps du poste peut être encore possible car nous avons accès a la médiathèque en direct. Mais la « featured image » est associé automatiquement quand je vais récupérer l’image via l’article. donc problème.

    J’espere qu’ils trouveront très vite la solution à ce problème très contraignant.
    j’aurai souhaité savoir si l’ajout de la ligne de code dont vous faite allusion dans votre article peut avoir des incidents sur le fonctionnement globale du site et des plugins installés? Avant de rajouter un tel code dans les fichiers de base du WordPress je veux vraiment m’assurer que je retrouverai les fonctionnalités que j’avais avant la mise à jour.

    Je vous remercie pour votre article, en espérante une réponse de votre part.
    Très bonne journée à tous.

    Dj PHANTOMZ

  3. La modification que je propose ne supprime aucune fonctionnalité.
    Dans tous les cas, tu peux essayer, et si pas d »amélioration, il te suffit de supprimer la fameuse ligne !

  4. Par ailleurs, je pense très honnêtement que c’est une mauvaise idée de se précipiter sur la MAJ majeure de WordPress !

    Il faut toujours attente la version 3.x.1 qui est souvent bien plus stable !

  5. je ne suis pourtant pas du genre pressé à la sortie des nouvelles versions du WordPress, d’ailleurs pour celle ci j’ai attendu jusqu’hier pour faire la mise à jour sur mon site principale, alors que sur un de mes autres sites cette nouvelle version tournais sans souci.
    Tu penses qu’ils sont du genre rapide à trouver une solution à ce genre de problème ?

  6. Merci Amaury, en ce mercredi bien pourri tu me sauve la vie (ça rime) !

    J’ai eu la mauvaise idée de me « précipiter » sur la 3.5 sur un site « en prod », j’aurai pas du (que ça me serve de leçon), merci encore pour l’astuce!

  7. Bonjour à tous,

    Depuis ma mise à jour en 3.5, je n’ai plus d’éditeur visuel, pourtant j’ai désactivé et ré activé les plug-ins et ça n’a rien fait.
    Puis je avoir des conseils svp.

    Quand il y a une nouvelle mise à jour qui sort, vous conseillez combien de temps pour la faire, car c’est vrai que j’ai toujours peur d’un piratage et j’ai tendance à le faire très vite.
    Merci et bonnes fêtes de fin d’année

  8. Merci beaucoup pour l’astuce qui a marché !
    J’ai mis à jour aujourd’hui, donc pas tout de suite et j’ai subi ce souci de script. Embêtant sur son site de production.

  9. Bonjour,
    Ma configuration est la suivante :
    WP 3.5
    Theme Akita de ThemeForest 1.1.5
    Je travaille sur en MAC 10.6.8

    Après avoir essayé sur GOOGLE CHROME et FF de :
    - vider le cache
    - passer d’1 navigateur à un autre
    - désactiver TOUS les plugins
    - re vider le cache
    - Passer au thème Eleven
    - ajouter define(‘CONCATENATE_SCRIPTS’, false);
    - ajouter define(‘WPE_DEBUG’, true);

    la fonction éditeur visuel n’est toujours pas disponible.

    SAUF sur le navigateur SAFARI 5.0.5 où tout roule !

    Que celui ou celle qui a une idée lumineuse lève la main !!!!

    Merci à tous

  10. Pingback : L’Hebdo WordPress : Bonne année 2013 – WordCamp Paris 2013 – WordPress 3.6 | WordPress Francophone

  11. J’ai également fait une mise à jour 3.5 et je n’ai plus d’éditeur, ni possibilité d’insérer un média dans un article.
    Si quelqu’un à une solution je suis plus que preneuse !
    Merci

  12. La solution que je propose ne fonctionne pas ?

  13. Avec la solution de désactive la concaténation Javascript, j’ai une légère progression : quand je double-clic (!!) sur le bouton des liens, une popup incomplète s’affiche tout en bas à gauche de l’éditeur !
    Malheureusement c’est ce que j’ai de mieux pour le moment et au moins je peux faire des liens :-(
    Le mode DEBUG ne me donne rien d’intéressant…
    Merci pour ton aide Amaury ;-)

  14. Je me réponds…
    En fait je ne peux valider la fenêtre de lien ni la fermer… (et bloque la rédaction de l’article!).
    Par contre les mots-clés fonctionnent à nouveau.

  15. Bonjour Amaury,
    Le probleme persistant (toujours pas fonction Editeur Visuel ni pour articles, ni pour pages, pas de barre de style et rien dans la fenetre à texte),
    j’ai :
    - rebasculé mon site en WP 4.3.2
    - refais les manip (vider cache, desactiver plugin, bien décocher la case dans Mon profil, …etc, etc..)
    - essayer sur FF 17 et Chrome 23 : ne fonctionne toujours pas
    -essayer sur Safari 5.0.6 : ne fonctionne pas
    …..
    -et aussi sur Safari 5.0.5 : ca FONCTIONNE !!!

    BIZARRE, non ?
    ET cela en ayant EXACTEMENT les mêmes préférences Safari pour les 2 versions.

    Quelle est donc la différence entre ces 2 safaris ?

    Mille mercis

    Alice

  16. Bonjour,
    Visiblement, certains ont un problème avec le Jquery 1.8.3 de WordPress 3.5.
    Ils ont téléchargé et installé un Jquery simple, mais ce n’est pas si simple…
    Et effectivement FF m’indique une erreur dès le début du Jquery chargé.
    Quelqu’un a essayé la dernière beta de WordPress ?
    Ben.

  17. @Alice

    Essayez le changement de langue. Retour à l’anglais en admin, C’est la seule chose qui avait résolu la disparition de l’éditeur visuel sur un de mes sites. Et dieu sait si j’avais fouillé les forums et essayé toutes les solutions proposées…
    Malheureusement ce problème semble récurrent (il n’est pas spécifique à cette mise à jour), ponctuel (il ne touche pas tant de monde que ça…) et multiforme (il n’est pas résolu de la même façon pour tout le monde) …

  18. Merci François.
    Malheureusement, pas de changement.
    J’ai donc vérifié le Error log file :
    “Premature end of script headers: editor_plugin.php “.

    Nouvelle piste :
    J’attends une réponse d’OVH car il pourrait y avoir un conflit lié au niveau de sécurité d’Apache entre le générateur de l’éditeur du theme (/framework/shortcodes/tinymce/editor_plugin.php) et le serveur Apache.
    Une extension d’Apache trop restrictive générerait cette Internal Server Error sur le serveur.

    A suivre !

  19. Quelques vieux threads à ce sujet. Ca peut donner une piste… Il y a beaucoup plus de choses dans les forums, mais je n’ai retrouvé que ça dans mes notes. Si vous résolvez le problème faites-en part ici, ça pourra toujours servir plus tard … ;) Merci

    http://wordpress.org/support/topic/tinymce-is-not-defined-1
    http://wordpress.org/support/topic/25-and-tinymce-not-working-in-visual-mode?replies=17
    http://www.wordpress-fr.net/support/viewtopic.php?pid=63984
    http://www.wordpress-fr.net/support/sujet-4833-tout-fait-mais-toujours-editeur-visuel

  20. Pour ma part, même chose, j’ai mis mes deux sites à jour:
    - aucun problème pour l’un
    - problème pour le deuxième

  21. PROBLEME RESOLU !
    J’espère que les résultats de mon investigation aideront certains !
    :-))
    En moins de 48h, OVH m’a répondu (merci OVH) :
     » une erreur 500 est due à:
    > -.htaccess
    > -Erreur de script
    > -Permissions/droits
    Le dossier de votre thème a les droits 777 actuellement, merci de les mettre à 755 au max à l’aide de votre client ftp.  »

    ET voilà ce qui générait le conflit entre le thème, l’interface WP et le serveur.
    J’étais donc trop permissive, un comble, non !

    Conclusions :
    1. Si vous avez achetez un thème : n’hésitez pas à faire fonctionner le service après-vente « débugs ». Merci Jason de ThemeForest.

    2. Récupérer et diffuser votre ERROR LOG FILE où sont écrits les bugs de votre site – cela aidera beaucoup à identifier la source du problème.

    BONNE ANNEE A TOUS,
    gardons patience et détermination

  22. Bonjour à tous,
    Je suis passé sous WP 3.5 et moi aussi je me suis rendu compte que je ne pouvais pas ajouter de médias en cliquant sur le bouton de la page d’ajout d’articles, comme indiqué ici.
    J’ai lu les solutions et les réponses.
    Dans mon cas, la solution d’Amaury ne règle pas le problème, malheureusement.
    Ni les autres solutions proposées ici.

    La mise à jour 3.5.1 est bien annoncée, mais réglera-t-elle le problème ?

    Est-ce que mon thème, qui date de deux ans environ peut être la cause ? Je viens d’en essayer un autre plus récent et je ne vois pas beaucoup d’évolution pour le problème principal qui me concerne. Mais je n’ai pas fait le tour complet du sujet, mon blog n’étant pas non plus très souvent utilisé pour poster.

    C’est vraiment dommage, car tout fonctionnait bien depuis plusieurs années.

  23. MAJ : en changeant de thème (passé sur Twenty-Ten pour voir), la seule différence est que maintenant une grande fenêtre « Insérer un média » s’ouvre en cliquant sur le bouton « ajouter un média ». Ce n’est pas la même fenêtre que j’avais avant.
    Toutefois, la bibliothèque est vide et si je veux y envoyer un fichier, j’obtiens toujours le message « Une erreur est survenue lors de l’envoi. Veuillez réessayer plus tard. » à la fin du processus d’envoi ???

    J’ai modifié les droits des dossiers comme indiqué plus haut par Alice, sans amélioration. J’avoue ne pas avoir modifié grand chose depuis la dernière fois que tout allait bien. Si ce n’est avoir fait la mise à jour vers 3.5 donc…

  24. J’ai exactement le même problème que Thierry et la sollution de Amaury n’a rien changé… Quelqu’un sait ce qu’il faut faire? (repasser sur la 3.4.2?)

  25. Le WorldCamp 2013 est dans quelques jours. Espérons qu’une mise à jour sera diffusée à cette occasion.
    Repasser à la 3.4.2 me fait un peu peur j’avoue…

  26. WorldCamp => WordCamp :)

    Aucune MAJ ne sera diffusée car c’est WP.org qui est en charge du développement, et l’évènement est organisé par WP-FR.net

    Par ailleurs, pour ceux qui rencontrent des problèmes, vous devrez probablement espérer une sortie rapide de la version 3.5.1 :
    http://core.trac.wordpress.org/milestone/3.5.1

    Ce qui me fait dire une fois encore, que si vos sites sont vitaux pour vous :

    1. Ne faites pas de MAJ précipité
    2. Tester la MAJ sur un environnement de développement

    Par ailleurs, je pense que le passage 3.5 => 3.4.2 est possible sans trop de problème car peu de changement dans le schéma DB !

    Petit tuto à suivre: http://etuts.org/manually-downgrade-wordpress/

  27. Une idée quand elle sortira la version 3.5.1? Ils ont prévu de résoudre les problème d’upload de médias? 83% ont été effectué en combien de temps? :)

    Oui prochaine fois j’attendrai avant de changer de version…

  28. bonjour, bon je suis sur un autre ordi pendant quelques jours, et je ne peux plus accéder à mon tableau de bord admin. Je ne sais pas si ce sont quelques manips suite au problème ci-dessus qui ont créé le problème.
    Voici le message obtenu en tentant d’accéder à la page d’admin (via http://www.xxxxxxx.com/wp-admin/admin.php , je ne me trompe pas ??) :
    Warning: Cannot modify header information – headers already sent by (output started at /homez.59/xxxxxxx/www/wp-config.php:1) in /homez.59/xxxxxxx/www/wp-includes/pluggable.php on line 876

    Merci de votre aide et désolé de ne pas forcément être dans le sujet. Mais c’est seulement pour mieux y revenir…

  29. Je me réponds à moi-même, et à ceux qui pourraient avoir le même problème : dans ce cas-ci, il s’agit d’un problème de type de sauvegarde de mon fichier « wp-config.php ».
    En effet, il a été sauvegardé en UTF-8 et non en ANSI.
    Voilà pour ça. Ça ne règle pas tout, mais on avance… :)

  30. Bonjour,

    sinon il existe une solution pour jouer avec les widget par exemple quand on ne peut plus des déplacer ou les modifier :
    aller dans option de l’écran (en haut à droite)
    et activer l’accessibilité;

    A partir de ce moment, vous pourrez modifier vos widgets.

    Malheureusement cette fonction n’est pas présentes dans les menus.

  31. http://www.xxxxxxx.com/wp-admin/

    Voici l’url du panneau d’admin… :)

  32. Salut les amis, j’étais comme certains d’entre vous depuis hier soir , impossible d’uploader les images avec wordpress 3.5 , j’ai cherché et lu des centaines de forums, rien , aucune solution n’a fonctionné jusqu’à celle-ci.

    LA solution ultime étant de de downgrader à 3.4.2, bref je n’ai pas eu à aller jusque là. La soluce je l’ai trouvé sur un site anglais, il faut donc rendre à cesar ce qui lui appartient, c’etait sur WordPress.org et l’auteur est Samuel Wood (otto) tech ninja ;).

    Voici ce que j’ai fait :

    1/ Supprimer de votre serveur via ftp wp-includes et wp-admin

    2/ uploader (apres avoir telecharger les fichiers originaux WP) les nouveaux dossiers vierges wp-includes et wp-admin

    3/ Vider cache et divers sur votre navigateur

    4/ Redemarrer votre nav et tester. Ca devrait marcher.

    Je savais que ct un probleme de javascript mais impossible à tracer donc la soluce d’uploader des fichiers propres me paraissait juste.

    Voila, bonne chance à ceux qui en ont besoin, et faites un retour. @+ Sportivement, Vince.

  33. Merci pour l’info, moi qui croyait que tout venait de moi ;)
    La première solution dans le fichier « config » est parfaite, ça roule pour moi!!!

    Encore merci,merci !!

    Info : version 3.5.1
    thème Alltuts

  34. Petit retour.
    Je suis bien passé en 3.5.1, mais le problème du bouton « Ajouter un média » ne fonctionne toujours pas.
    Je désespère complètement là… :(

  35. salut, avant toute operation fais un save complet de ta base et de ton blog en general (parametres, themes…). ensuite tu peux supprimer ton dossier wp-includes sur ton serveur et re-upload un dossier propre original de wp-includes. vide ton cache et relance ton wordpress te teste l’ajout d’images, refais nous un retour ici pour le resultat. A+.

  36. Merci Vince,
    Mais le remplacement de wp-includes n’a rien modifié du problème.
    C’est pas que j’y tiens absolument, mais j’ai bossé sur mes articles depuis trois ans, et c’est triste de constater que je ne peux plus mettre d’images. Vraiment dommage.

  37. Bonjour,

    Je m’immisce dans cette conversation.

    Cette solution n’a rien changé de mon côté. Lorsque j’étais passé à la 3.5 j’avais effectivement rencontré quelques soucis Jquery (possiblement liés à mon thème si j’en crois ce que j’ai lu mais sans pouvoir les régler) et j’avais contourné le problème avec le fameux define(‘CONCATENATE_SCRIPTS’, false); mais depuis le passage à la 3.5.1, certains éléments pilotés par Jquery dans l’admin fonctionnent toujours(menus déroulants par exemple) en revanche d’autres comme l’ajout d’une image à la une de l’édition d’un article ne fonctionne plus, la fenêtre d’ajout d’image ne s’affiche plus dans une iframe (ou thickbox) mais charge une nouvelle page…

    Qu’est-ce qui pourrait être la cause de ce problème au niveau du thème ? Une ancienne version de Jquery appelée ?

    Merci
    Thomas

  38. re-Bonjour,

    En fait il y a pas mal de choses qui ne fonctionnent plus, par exemple insertion d’un lien dans un article ne fonctionne plus via l’éditeur, lorsque je valide le lien je reviens à la liste des articles… Je viens de tester en changeant de thème (pour le Twenty Twelve par exemple) ça règle tous les problèmes…

  39. Il est vrai que j’utilise un vieux thème qui n’a pas été mis à jour depuis longtemps (Arjuna). Je vais faire le test d’en changer. Ce sera moins compliquer que tout refaire. Merci Thomas.

  40. L’activation de la dernière version du thème officiel règle tous mes problèmes Jquery de l’admin… cela étant pour ma part je ne souhaite pas le refaire j’aimerai plutôt comprendre ce qui ne va pas dans le mien.

  41. Pour moi ça marche, mais le glisser/déposer dans la zone widget ne marche pas.

  42. Pour ma part, j’en suis certain le problème vient de mes thèmes.
    Mais je m’interroge (et ce n’est sûrement pas le bon endroit pour en parler), pourquoi un JQuery (ou un JS qui en dépend) appelé sur mon thème vient-il parasiter le JQuery qui est responsable du bon fonctionnement de l’admin ? Il n’y a aucune moyen de distinguer le front et back office à ce niveau ?

  43. Je ne suis pas spécialiste, loin de là, mais je me pose aussi la même question que Thomas : en quoi le thème « publique » peut aussi concerner l’affichage perso de l’admin ? Les mystères de WordPress…

  44. Techniquement, c’est possible de différencier les 2 parties (public/privé);

    C’est juste une question de méthode de développement, WordPress permet de faire des choses propres, et des choses pas propres…

    Si le JS du thème interagit en backoffice, c’est que le thème n’est pas très bien développé.

  45. @Amaury

    Cela en pourrait-il pas s’expliquer si un thème emploie une interface d’options utilisant js dans l’admin ?

  46. Alors il semble difficile de garder un thème longtemps dans ces conditions. Il faut donc se préparer à en changer de temps en temps, si les créateurs ne font pas de mises à jour régulièrement.
    Comment dans ce cas bien choisir un thème qui durera au moins quelques années ?

  47. Bonjour à tous,

    en désespoir de cause, ayant testé toutes les idées et solutions proposées un peu partout (dont aucune ne fonctionnait pour moi et encore moins après la dernière màj de WP), je me suis résolue à chercher parmi mes plugins et… bingo, j’ai trouvé le fauteur de troubles : il s’agit de Contact Mail Cispm. Donc si vous l’utilisez, ne cherchez pas plus loin et séchez vos pleurs !

    J’ai installé cformsII (http://www.deliciousdays.com/cforms-plugin/) sur un blog et Contact Form (assez rudimentaire, mais peut suffire : http://bestwebsoft.com/plugin/contact-form/) sur un autre histoire de tester plusieurs options et tous mes problèmes sont maintenant résolus.

    Voilà, si ça peut servir… :-)
    Alexandra

    • Mille mercis Alexandra, j’ai galéré des heures jusqu’au moment où j’ai lu ton commentaire et que je me suis aperçu que moi aussi j’avais ce pluggin. Désactivé et pouf, problème envolé !

  48. Il y a l’option de prendre un theme « premium » chez un « gros » fournisseur. Chez celui que je connais, les thèmes sont suivis et mis à jour régulièrement. Evidemment, ce n’est pas très agréable si on est attaché à un web divers et atomisé… ;) Sinon, un développeur « seul » peut également suivre ces thèmes. mais s’il en réalise beaucoup, il finit vite par être débordé, j’imagine.

  49. Vérifiez vos fichiers wp-settings s’ils ne comportent pas des valeurs non conformes / fichier original , j’ai reglé un de mes pblms de ce genre aussi avec ca

  50. J’avais le même problème…je viens à l’instant de résoudre !

    Mon thème ‘minimatica’ n’était en fait pas compatible avec la version 3.5 de WordPress. En fouillant sur les forums je suis tombée sur ça :

    What you need to do to fix this issue is to open functions.php (wp-content / themes) and find this line:

    add_filter( ‘ext2type’, ‘minimatica_mime_types’ );

    And replace it with this:

    add_filter( ‘ext2type’, ‘minimatica_file_types’ );

    Je ne sais pas du tout si le code est le semblable à tous les thèmes (en remplaçant le nom du thème bien sur) mais ça vaut peut être le coup de jeter un coup oeil…

    Si cela ne fonctionne pas essayer de changer de thèmes, si vous parvenez à insérer des images avec un nouveau thème le problème vient alors de votre thème actuel…vous ne serez peut être pas plus avancés mais au moins vous serez d’où vient l’erreur.

    N’hésitez pas à contacter votre hébergeur, le mien m’a vraiment bien aidé !!

  51. Bonjour,

    Je viens de régler mon problème également. Nous l’avions vu ce type de problème est souvent lié à un conflit en un JQuery flambant neuf embarqué pour le backoffice WP et un JQuery vieillissant lié au thème. Pour empêcher la version du thème de se charger dans l’admin WP (s’il est appelé dans le fichier functions.php du thème notamment), c’est assez simple, il faut repérer dans le thème l’appel au JQuery et l’encadrer dans un condition :

    if ( ! is_admin() ) {
    /*Ici l’appel JQuery */
    };

    Pour moi ça fonctionne à merveille, le thème et l’admin fonctionnent.

    J’espère être clair.
    Thomas

  52. @Thomas :
    votre astuce marche (même si la barre Web Dev se plaint d’erreurs JS…), j’ai rajouté votre condition (!is_admin()) autour de l’appel du JQuery :
    Dans mon thème « Arjuna X », dans wp-content/themes/arjuna-x/functions.php, à la ligne 3818. Effectivement le JQuery appelé est en 1.8.10 !
    Je ne suis pas certain que ce thème soit mis à jour un jour, je vais peut être en changer…

    Sans rentrer dans un troll, si je comprends bien, le thème choisi s’applique tant à l’interface admin que l’interface visiteur ? original et troublant…
    J’espère que d’autres s’en sortiront aussi !
    Merci Thomas !

  53. J’avais aussi Arjuna, et finalement je l’ai changé et les problèmes sont réglés.
    Mais jusqu’à quand, car si on est dépendant des thèmes, c’est pas gagné.

  54. Je crois que dès lors que l’appel est fait via le functions.php (mais je dis peut-être une connerie), cela impacte l’admin. Mais rien d’étonnant puisque certains thème sont paramétrables depuis l’admin, ils l’impactent nécessairement.

  55. Effectivement, le fichier functions est chargé à la fois en front-office et en backoffice. C’est l’objectif du fichier.

    On peut entre-autre déclarer le nombre de sidebars, de menus, etc.
    Les bons développeurs de thèmes conditionne les modifications sur jQuery avec la fonction is_admin()

  56. @Thomas @Ben :
    Salut à vous, j’ai les même symptômes que vous ! par contre pas d’inclusion Jquery dans mon function.php. Pourriez-vous me montrer la ligne d’inclusion ?

    Merci d’avance

  57. @Marc : cherche la ligne suivante (à peu près..) :
    –> wp_enqueue_script(‘arjunaJQueryMinJS’, get_template_directory_uri() .’/lib/jquery-ui-1.8.10.custom.min.js’);
    c’est bien la fonction wp_enqueue_script() qui charge les scripts nécessaires au thème ; quand la fonction appelle un vieux JQuery (1.8.3 chez moi), il faut rajouter la condition (!is_admin()). Cherche une ligne contenant « jquery-XXXX.js ».
    http://codex.wordpress.org/Function_Reference/wp_enqueue_script
    PS : visiblement, le fichier functions.php a été réécrit chez moi et le numéro de ligne précédemment indiqué a changé. Peu importe.

  58. @Ben merci beaucoup pour ta réponse si rapide!
    Effectivement la fenêtre s’ouvre désormais! mais par contre lorsque j’ajoute une image à la une lors de la mise en ligne pour chaque image j’ai ce message « Une erreur est survenue lors de l’envoi. Veuillez réessayer plus tard. » Mais l’image est bien ajouter dans média.

  59. Apparemment c’est un conflit avec mes customs post type qui est apparut avec la version 3.5 car si je ne les inclus pas tous mes problèmes disparaissent.

  60. Je ne suis pas très fort en WordPress, je ne saurais expliquer les erreurs.. j’applique juste les astuces des autres !

  61. J’ai pu trouver ce qui ne fonctionnait pas ! pour certain custom post type j’ajoutais un icône pour les différencier dans l’admin! Il suffit de désactiver ce bout de code si jamais quelqu’un avait le même problème :
    if (is_admin())
    {
    add_action( ‘admin_head’, ‘wpc_cpt_icon’ );
    function wpc_cpt_icon()
    {
    ?>
    ici le style de votre icone
    <?php
    }
    }

    merci encore, j'en ai fini des problème avec la version 3.5 :)

  62. Bonjour,

    Je viens de faire la mise à jour de wordpress en 3.5.1 et je rencontre le même problème que tout le monde : Impossible « d’ajouter un média » + onglet « texte » inaccessible.
    J’ai lu pas mal de vos commentaires et ton article également Amaury mais je ne comprends rien à vos explications qui sont bcp trop « techniques » pour moi. Même si je me pensais assez calée (j’ai tout fait toute seule sur mon blog) là je suis totalement larguée…

    N’avez vous rien de plus simple ? Car j’utilise cette fonction d’ajout d’images très souvent dans mes articles … et là je voulais publier un article car je n’ai pas publié depuis longtemps et je m’en trouve bloquée…

    Merci beaucoup ;)

  63. Super tuyau… merci beaucoup tout fonctionne très bien à présent… avec la simple ligne de code dans mon fichier wp-config.php
    define(‘CONCATENATE_SCRIPTS’, false);
    comme tu l’as indiqué…
    mille mercis,
    un wpuser reconnaissant ;-))

  64. Regarder si vous utiliser la la fonction underscore.js si c’est le cas alors mettez le à jour ! J’ai remarquez que la version 1.3.3 était problématique chez moi !

  65. @Amaury merci beaucoup, j’ai de nouveau accès à l’éditeur de texte et je peux insérer mes photos en plus solution facile à mettre en place, bonne journée.

  66. moi aussi j’ai retrouvé l’éditeur !! haaa ca fait du bien ! merci

  67. Bonjour,

    J’ai également le même problème et ne sait pas où trouver le fichier de configuration sur la console d’admin ! Est-ce qu’il est accessible via la console d’ailleurs ?

    Merci,
    Jérémie

  68. Vivement que la mai sorte, j’ai ce soucis sur le site d’un client.

    J’ai essayé toutes les méthodes que j’ai pu trouver, mais rien n’y fait.

  69. Merci bien en effet c'était là la solution, inscrire la commande
    define ('concatenate_scritps", false);
    dans le wp-config

    Encore merci

  70. Pingback : Galère avec WordPress 3.5 : arrêtez de vous mordre les doigts ! - Ressources Webdesign

  71. Bonjour
    j'ai ce problème de disparition de l'éditeur visuel, malgré que j'ai copié-collé define ('concatenate_scritps", false); à la fin du fichier wp-config, ça n'as pas réglé le problème (je suis sous wordpress 3.5)
    Y a t'il une autre solution ??
    Merci

  72. Bonsoir
    Idem, je ne sais plus quoi faire :(
    A quel niveau de wp-config, faudrait il insérer ces lignes ?
    Merci

  73. Même soucis qui recommence quelques versions après…
    @Alain, tu peux les mettre n'importe ou dans le wp-config

  74. Merci pour ce article c’est très intéressent, Mais quelqu’un peut me donner un lien ou je trouve plus concernant ce sujet, je fais mes recherches dans le même domaine, et je veux savoir plus stp.
    Merci d’avance.

  75. Bonsoir
    Idem, je ne sais plus quoi faire :(
    A quel niveau de wp-config, faudrait il insérer ces lignes ?
    Merci

Laisser un commentaire